1 (2020-04-19 21:58:58 отредактировано toxa)

Тема: quik 8.5 & lua 5.3

в связи с грядущим выпуском нового квика с новой версией lua ( скачать тут: ftp://ftp.quik.ru/public/updates/8.5/ ) , предлагаю пообщаться на тему перевода библиотек.  есть несколько интересных тем:
1. нужно ли в либах оставлять обратную совместимость? стаб lua.5.1.dll остался...
2. все что 32 бита, судя по всему, умрет. 32-х битного квика с lua 5.3 ожидать не приходится.
ну и так далее.

2

Re: quik 8.5 & lua 5.3

жесть вообще глючное все. lua_version() возвращает 0.0 smile

3

Re: quik 8.5 & lua 5.3

toxa пишет:

жесть вообще глючное все. lua_version() возвращает 0.0 smile

это нормально, все по плану, обиженные инвесторы, потные луа-кодеры. все так и задумывалось и это циклично.

4

Re: quik 8.5 & lua 5.3

toxa пишет:

в связи с грядущим выпуском нового квика с новой версией lua...

обратная совместимость точно не нужна, танцев с бубном и так хватает

5 (2020-05-19 13:20:42 отредактировано swerg)

Re: quik 8.5 & lua 5.3

Наконец-то ARQA на форуме разродилась с ответом по поводу lua.5.1.dll в QUIK 8.5.
Судя по всему оставили они её "по приколу", сами на знают для чего, как она работает и что содержит.
Цитата с их форума:

Начиная с версии торгового терминала 8.5 все QLUA скрипты должны
   быть адаптированы под LUA 5.3. Это в частности означает, что все
   внешние библиотеки должны быть залинкованы на библиотеку lua53.dll.

   Библиотеку lua5.1.dll, оставленную в дистрибутиве на "переходной"
   период, использовать не следует. В дальнейшем
   lua5.1.dll будет удалена из дистрибутива.

6

Re: quik 8.5 & lua 5.3

toxa пишет:

1. нужно ли в либах оставлять обратную совместимость? стаб lua.5.1.dll остался...

Обратную совместимость на уровне бинарного файла сделать невозможно. Т.к., с одной стороны, хоть интерфейс многих функций API для Си всё же не поменялся, однако Lua в QUIK 8.0 и 8.5 собраны с разной поддержкой для double / integer, так что даже если сделать динамическую линковку с той DLL, какая найдена, то наверняка где-то бинарно разъедется. Ну и зачем это счастье надо.

Я думаю, проще делать 3 варианта скомпилированных DLL (если требуется поддержка всех версий) и, соответственно, иметь 3 конфигурации сборки для проекта:

  • вариант x86 (32-битная платформа) с Lua5.1 для QUIK 6 и 7

  • вариант x64 с Lua5.1 для QUIK 8.0..8.4

  • вариант x64 с Lua5.3 для QUIK 8.5 и далее

Если не пользоваться новыми возможностями API для Lua5.3, то поддерживать такой вариант вполне возможно.

7 (2020-05-20 20:56:12 отредактировано toxa)

Re: quik 8.5 & lua 5.3

не, ну как невозможно... можно искать lua5.3, динамически линковаться с ней, если не удалось - искать lua5.1 и линковаться с ней. дальше в коде возможны разные варианты, можно сделать некий stub который будет скрывать разницу...

ну не важно. меня интересует прогноз, насколько долго проживет quik с lua 5.1. потому что даже 7 версия, например, как бы не умирает и не умирает... мы не знаем, сколько займет переход на версии больше чем 8.5, вот я о чем. тянуть старый код не охота.

8 (2020-05-21 07:30:56 отредактировано swerg)

Re: quik 8.5 & lua 5.3

toxa пишет:

меня интересует прогноз, насколько долго проживет quik с lua 5.1. потому что даже 7 версия, например, как бы не умирает и не умирает... мы не знаем, сколько займет переход на версии больше чем 8.5, вот я о чем. тянуть старый код не охота.

Это какие-то не технические досужие разговоры, как по мне wink
Известно, что ARQA поддерживает возможность подключения старыми версиями терминала очень долго, так что терминалы с Lua 5.1, как и 32-битные терминалы, будут работать еще много лет.
А дальше выбор зависит от вас и от того, для чего/кого вы делаете роботов. Если для себя - вы сами легко выберите для себя подходящий момент перехода. Если для сторонних людей - то вынуждены будете еще долго тянуть совместимость.

Судя по опыту, до конца этого года версия 8.5 или пришедшая ей на смену точно станет очень стабильной.

9

Re: quik 8.5 & lua 5.3

swerg пишет:

Известно, что ARQA поддерживает возможность подключения старыми версиями терминала очень долго, так что терминалы с Lua 5.1, как и 32-битные терминалы, будут работать еще много лет.

Точно нет, до конца года будет полностью переход на 8.5+, даже 8.4 работать не будет. Так решила даже не моекс.
Новые формулы, которые в 7+ нет совсем и делать там их никто не будет, а в 8.4 еще не все прописаны.

10

Re: quik 8.5 & lua 5.3

Я никакой квик не использую, мне по барабану. Просто очень не хочется тащить совместимость со старыми версиями, мало было 32 бит, еще теперь разные версии lua. wink)